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1 ИЗУЧЕНИЕ СРЕДЫ РАЗРАБОТКИ                             
VISUAL C++ 6.0 

 
Создание приложений для работы в операционной среде 

Windows на языке Visual C++ включает следующие этапы: 
• Написание текстов программ. 
• Создание файлов ресурсов для описания диалоговых 

окон, меню, панелей инструментов, значков и т. п. — элементов 
управления работой программы. 

• Разработка системы помощи для работы с программой. 
• Компилирование исходных текстов программ. 
• Компоновка программы их компонентов. 
• Отладка и модификация программ. 
 
Опишем некоторые, наиболее популярные, бесплатные ком-

пиляторы C++, знание которых ускорит процесс освоения среды 
разработки программ. Можно отметить, что Microsoft Visual C++ 
компилятор является не единственной интегрированной средой 
разработки программ С++, которые популярны и широко исполь-
зуются программистами. Выделим небольшую часть компилято-
ров, среда разработки которых удобна для пользования начи-
нающих программистов С++. 

 

1. Microsoft Visual C++ Express (http://msdn.microsoft.com/ 
vstudio/express/visualc/) — бесплатный компилятор для Windows 
и .NET. 

 

2. Eclipse C++ Development Tools [http://www.eclipse.org/cdt/] — 
плагин разработки С++ для Eclipse. Работает с MinGW32, хотя 
можно подключать и другие компиляторы. Удобный интерфейс, 
средства для коллаборации разработчиков и UML-разработки 
присутствуют.  

 

3. Dev C++ [http://www.bloodshed.net/devcpp.html] — вторая 
по популярности среда разработки для C++. Поддерживает GCC 
компилеры, подсветку, auto-complete, шаблоны, профайлинг, де-
баггинг, class-view и прочий стандартный набор для такого рода 
программ. Интерфейс удобный, присутствуют средства для рабо-
ты с CVS. 
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4. Code::Blocks [http://www.codeblocks.org/] — бесплатная 
среда разработки под C++.  

 
5. Digital Mars [http://www.digitalmars.com/].  
 
6. Visual GWin++ [http://sourceforge.net/projects/visual-gwin/ 

files/].  
 
7. MinGW Developer Studio [http://www.mingw.org/] — про-

грамма для Windows (Minimalist GNU for Windows). По существу 
это порт GNU Compiler Collection (GCC) для Windows плюс бес-
платная коллекция, включающая типовые заголовочные файлы и 
библиотеки.  

 
8. C++ Builder [http://www.embarcadero.com/ru/products/cbuilder] — 

среда для действительно быстрой разработки приложений на 
С++. Огромное количество возможностей. 

 
9. KDevelop [http://kdevelop.org/] — стабильная среда разра-

ботки Си++/Си, даёт хорошую интеграцию с инструментами QT 
[http://qt-project.org/]. 

 
10. Open Watcom [http://www.openwatcom.org/index.php/ 

Main_Page] — проект сообщества открытого кода по поддержке и 
развитию многоплатформных компиляторов Watcom C, C++ и 
Fortran и сопутствующих программ. 

 
Каждый из указанных выше компиляторов позволяет разра-

ботать программы С++, однако часть из них может быть исполь-
зована лишь для разработки небольших по объему программ. 
Предлагается читателям воспользоваться ссылками и протести-
ровать компиляторы, выбрать наиболее удобный и понятный для 
себя компилятор. Однако для практики, конечно же, важным и 
необходимым является компилятор Microsoft Visual C++. 
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1.1 Пользовательский интерфейс Visual C++ 6.0 
 
Приведем внешний вид окна рабочего пространства среды 

Visual C++ 6.0. Рабочая область разделена на две части: окно ра-
бочей области и окно редактирования.  

Для графического отображения объектов рабочей области 
используется список с древовидным отображением, корневыми 
узлами которого являются проекты. Содержимое этих проектов 
можно представить тремя способами, каждому из которых соот-
ветствует вкладка в нижней левой части рабочей области: 

• ClassView — представляет программу в объектно-ориен-
тированном виде, отображая классы С++, их методы и члены-
данные. Двойной щелчок такого объекта вызовет переход к его 
объявлению или реализации; 

• ResourseView — отображает ресурсы, сгруппированные 
по категориям. Двойной щелчок объекта загружает соответст-
вующий редактор; 

• FileView — показывает все файлы проекта, которые мож-
но редактировать. 

 
Если щелкнуть объект правой кнопкой мыши, появится кон-

текстное меню, пункты которого связаны с этим объектом. 
Для работы с файлами в редакторах программ и ресурсов 

используется окно редактирования. Если Вам не хватает в нем 
пространства, выберите из меню View опцию FullView. 

 
1.2 Меню и панели инструментов 
 
Среда разработки Visual C++ обладает набором меню, по-

зволяющим управлять файлами и рабочими областями проектов, 
настраивать саму среду, а также обращаться к справочной систе-
ме, программе управления исходным кодом и внешним инстру-
ментальным средствам. Почти каждому меню соответствует па-
нель инструментов, в которой команду можно выбрать одним 
щелчком кнопки мыши. Панели инструментов допустимо на-
страивать — добавлять и удалять кнопки, скрывать и отображать 
сами панели инструментов. Поэтому вы можете сконфигуриро-
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вать среду по своему вкусу, упростив доступ к часто используе-
мым вами пунктам меню.  

По умолчанию в окне среды Visual C++ отображены три па-
нели инструментов. Панель Standart (содержит команды, часто 
используемые при работе с файлами), Build (команды, необходи-
мые для сборки и запуска приложений) и WizardBar (представ-
ляет инструменты для работы с классами).  

При щелчке правой кнопки мыши на поле расположения 
панелей (например, в пустой правой верхней части панели инст-
рументов) появится полный список возможных панелей, позво-
ляющий скрывать и отображать панели. 

Показанное ниже упражнение позволит Вам получить опыт 
в настройке пользовательского интерфейса. 

Задача: добавление кнопки в панель инструментов: 
1. В меню Tools выберите пункт Customize. Появится диа-

логовое окно Customize. 
2. Перейдите на вкладку Commands. 
3. В списке Category выберите пункт View. 
4. Щелкните значок Full Screen (третий слева в первом ря-

ду). Обратите внимание на описание команды, которое появляет-
ся под раскрывшемся списком Category. 

5. Перетащите значок Full Screen на панель инструментов 
Standart. 

6. Закройте окно Customize. 
7. Откройте файл с исходным кодом программы, дважды 

щелкнув его в окне FullView. 
8. Испытайте новую кнопку — щелкните ее, чтобы перейти 

в полноэкранный режим. Чтобы вернуться к традиционному ви-
ду, необходимо снова щелкнуть эту кнопку. 

 
Чтобы удалить кнопку с панели инструментов, достаточно 

щелкнуть ее правой кнопкой мыши и выбрать из контекстного 
меню пункт Delete. 

Помимо жестко установленных на панели кнопок, можно 
определять так называемые «быстрые» клавиши. Рассмотри алго-
ритм установки такого объекта. 

1. В меню Tools выберите пункт Customize. Появится диа-
логовое окно Customize. 
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2. Щелкните вкладку Keyboard. 
3. В раскрывшемся списке Category выберите опцию View. 
4. В списке Commands укажите ToggleFullScreen. Обратите 

внимание на описание команды, появившееся под раскрывшимся 
списком Category. 

5. Щелкните после ввода Press new shortcut key, после чего 
нажмите на клавишу PAUSE. 

6. Щелкните кнопку Assign.  
7. Закройте диалоговое окно Customize. 
8. Нажмите клавишу PAUSE. При этом окно редактирова-

ния должно переключаться из оконного в полноэкранный режим 
и обратно. 

 
Рассмотрим некоторые, самые часто используемые, коман-

ды меню. Подменю File служит для работы с проектом в целом, а 
также с его файлами.  

Команда File ⇒ New вызывает диалоговое окно для созда-
ния нового файла (подопция Files), проекта (подопция Projects), 
рабочего пространства (подопция Workspaces) или других доку-
ментов (подопция Other Documents). 

Команда File ⇒ Open позволяет открыть существующий на 
жестком диске (или дискете или СД) файл. 

Команда File ⇒ Close закрывает файл, имеющий фокус вво-
да (расположение курсора мыши). 

Команда File ⇒ Open Workspaces открывает существующий 
файл с описанием рабочей области. 

Команда File ⇒ Save Workspaces запоминает изменения в 
рабочей области. 

Команда File ⇒ Close Workspaces вызывает закрытие рабо-
чей области с одновременным сохранением изменений. 

Команда File ⇒ Save (Save as, Save All) позволяет сохранить 
файл, сохранить файл с новым именем или сохранить несколько 
файлов одновременно. 

Команда File ⇒ Page Setup выводит диалоговое окно для ус-
тановки размеров верхнего и нижнего колонтитулов и полей 
страницы. 
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Команда File ⇒ Print позволяет из соответствующего диало-
гового окна распечатывать указанный диапазон страниц. 

Команда File ⇒ Recent Files (Recent Workspaces) выводит 
список файлов и рабочих областей, которые использовались по-
следними, для их быстрого открытия. 

Команда File ⇒ Exit завершает работу с Visual C++. 
 
Подменю Edit служит для редактирования текстов, поиска и 

замены, задания закладок и точек остановки для отладки про-
граммы. 

Команда Edit ⇒ Undo отменяет операцию, выполненную 
последней. Повторное нажатие вызывает отмену предыдущей 
операции. 

Команда Edit ⇒ Redo восстанавливает последнюю операцию. 
Команда Edit ⇒ Cut переносит выделенный участок файла в 

буфер обмена с удалением выделенного из самого текста файла. 
Команда Edit ⇒ Copy копирует выделенный участок файла 

в буфер без его удаления из текста. 
Команда Edit ⇒ Paste копирует содержимое буфера в то ме-

сто файла, где установлен курсор. 
Команда Edit ⇒ Delete удаляет выделенный участок без ко-

пирования в буфер. 
Команда Edit ⇒ Select all выделяет весь файл. 
Команда Edit ⇒ Find (Find in Files) открывает диалоговое 

окно, в котором необходимо указывать, какой текст следует ис-
кать и в каком направлении (от начала к концу файла или наобо-
рот). 

Команда Edit ⇒ Replace производит замену одних выраже-
ний другими. 

Команда Edit ⇒ Go To позволяет перейти к адресу, полу-
ченному при выполнении отладки, к закладке, к строке с задан-
ным номером, к следующей ошибке, найденной при компиляции 
программы. 

Команда Edit ⇒ Bookmarks устанавливает именованные за-
кладки для быстрого перемещения по тексту программы. 

Команда Edit ⇒ Advanced активизирует меню третьего 
уровня со следующими командами: 
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• Increment Search — производит поиск по мере набора тек-
ста для поиска, 

• Format — устанавливает отступы в выделенном участке 
текста, 

• Tabify Selection (Untabify) — преобразует символы табу-
ляции в пробелы и обратно, 

• Make Selection Uppercase (Lowercase) — переводит вы-
бранные символы табуляции в пробелы и обратно, 

• Whitespace — вставляет символы-заполнители для знаков 
табуляции и пробелов. 

Команда Edit ⇒ Breakpoints позволяет установить точки ос-
танова для выполнения отладки программы. 

Команда Edit ⇒ List Members позволяет вывести полный 
список членов класса или структуры после набора оператора дос-
тупа к его члену. 

Команда Edit ⇒ Type Info выводит описание любого иден-
тификатора программы, на котором находится курсор. 

Команда Edit ⇒ Parameter Info выводит описание аргумен-
тов функции при наборе ее имени и открывающейся скобки. 

Команда Edit ⇒ Complete Word позволяет автоматически 
завершить набор слова, если в списке доступных слов имеется 
единственное слово, имеющее начало, которое уже подобрано. 

 
1.3 Настройка параметров среды 
 
Выбрав в меню Tools пункт Options, можно вызвать диало-

говое окно Options. В этом окне настраиваются параметры Вашей 
рабочей среды, от которых зависит вид и возможности встроен-
ных в нее инструментальных средств. Данные параметры приме-
няются ко всем проектам и их конфигурациям. 

В диалоговом окне можно настроить: 
1) редактор кода — начиная с параметров окна и сохранения 

и заканчивая параметрами таких функций, как автозаполнение 
кода и цветовое выделение синтаксических элементов. Можно 
эмулировать некоторые версии редакторов; 

2) отображение информации отладчиком; 
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3) параметры встроенной программы управления исходным 
кодом; 

4) пути к исполняемым файлам, файлам с исходным кодом, 
включаемым файлам и библиотекам. 

 
1.4 Система помощи приложения 
 
Visual Studio 6.0 поставляется вместе с библиотекой MSDN 

(Microsoft Developer Network). Это справочник разработчика, со-
держащий более 1 Гб технической информации по всем сторонам 
программирования (включены: документация, технические ста-
тьи, образцы кода и много другой информации о программирова-
нии на продуктах фирмы Microsoft). Библиотека MSDN запуска-
ется в собственной среде, основанной на HTML и снабженной 
быстрой поисковой системой. Несмотря на внешнюю изолиро-
ванность, программа MSDN интегрирована в среду разработки 
Visual C++. 

В Windows существуют три типа сообщений, посылаемых в 
тот момент, когда пользователь обращается к справочной системе: 

1) WM_COMMAND; 
2) WM_HELP; 
3) WM_CONTEXTMENU. 
Когда пользователь выбирает в меню команду Help, система 

посылает сообщение WM_COMMAND. Для отображения соот-
ветствующей справки вы должны перехватить это сообщение и 
вызывать систему WinHelp. 

Когда пользователь щелкает правой кнопкой мыши на неко-
тором элементе программы, посылается сообщение 
WM_CONTEXTMENU. Надо перехватить это сообщение и вы-
вести его в данном месте контекстного меню.  

 
*.h Файлы заголовков содержат определения идентификаторов 

ресурсов и идентификаторы тем справок, которые будут ис-
пользоваться в программе 

*.hm Файлы адресации справок содержат идентификаторы тем 
справки. Этот файл генерируется всякий раз, когда компили-
руется приложение (не рекомендуется вносить в него измене-
ния) 
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*.rtf Файлы расширенного текстового формата содержат тексты 
справок по каждой теме 

Name.cnt Файл таблицы содержания вкладки Contents (Содержание) в 
диалоговом окне Help Topics. Этот файл оглавления постав-
ляется вместе с приложением в дополнение к файлу *.hlp 

Name.hpj Файл проекта справочной системы объединяет файлы *.hm и 
*.rtf, совместно используемые при компиляции файла *.hlp 

 
Когда пользователь обращается к справочной службе лю-

бым другим способом (например, используя горячую кнопку F1), 
большая часть работы выполняется специально встроенным об-
работчиком событий. В данном случае перехватывается сообще-
ние WM_HELP.  

При использовании интерактивной справочной системы ис-
пользуется большое количество различных файлов. Конечным 
продуктом является файл, имеющий расширение *.hlp. Он созда-
ется на основе нескольких файлов. В приведенной ниже таблице, 
слово Name следует заменить на имя *.ехе файла приложения. 
Известны следующие расширения файлов, служащих для разра-
ботки компонент справочной системы. 

 
1.5 Параметры конфигурации проекта 
 
При работе над проектом в некоторых случаях возникает 

необходимость изменения параметров конфигурации проекта. Для 
этого вызовите окно Project Settings, выбрав в меню Project пункт 
Settings. В этом окне можно настроить параметры проекта, в том 
числе и параметры компиляторов и компоновщика Visual C++. 

Важно отметить, что изменения параметров на любой 
вкладке влияют только на текущий проект и версию сборки, ука-
занные в раскрывающемся списке Settings For. Для каждого типа 
сборки можно задать свой набор параметров. Если требуется ус-
тановить одинаковые параметры для всех версий сборки, в спи-
ске Settings For щелкните All Configurations. 

Не менее важно при настройке проекта проверить, какую 
его конфигурацию Вы изменяете. 

Приведем описание содержания некоторых вкладок диало-
гового окна Project Settings. 
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• General Settings — Здесь можно указать, компоновать ли 
программу с использованием статических библиотек MFC (если 
вы решили изменить способ компоновки, выбранной вами в окне 
мастера AppWizard). Также можно задать каталоги, в которые 
будут помещаться конечные файлы. 

• Debug Settings — Здесь находятся параметры, передавае-
мые программе при ее запуске в отладчике. Кроме того, можно 
использовать переадресацию ввода/вывода, аналогичную приме-
няемой в командной строке. 

• C/C++ Settings — Здесь вы определяете параметры ком-
пилятора, функциональные возможности языка, соглашения о 
вызове, параметры, связанные с типом процессора, оптимизации 
кода, константами препроцессора, и т. п. 

• Linker Settings — На этой вкладке выбирают дополни-
тельные библиотеки, которые следует скомпилировать вместе с 
вашей программой. 

 
1.6 Типы мастеров проектов 
 
В среде Visual C++ можно строить различные типы проек-

тов. Такие проекты после их создания можно компилировать и 
запускать на исполнение. Фирма Microsoft разработала специаль-
ный инструментарий, облегчающий и ускоряющий создание про-
ектов в среде Visual C++. 

Рассмотрим некоторые типы проектов, которые можно соз-
давать при помощи различных средств (мастеров проектов) 
Microsoft Visual C++: 

MFC AppWizard (exe) — при помощи этого мастера прило-
жений можно разработать проект Windows-приложения, имею-
щего однодокументный, многодокументный или диалоговый ин-
терфейс. Однодокументное приложение может предоставлять 
возможность пользователю в любой момент времени работать 
только с одним документом в окне. Многодокументное приложе-
ние, напротив, может одновременно представлять несколько до-
кументов, каждый в собственном окне. Пользовательский интер-
фейс диалогового приложения представляет собой единственное 
диалоговое окно. 
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MFC AppWizard (dll) — этот мастер приложений позволяет 
создать структуру DLL, основанную на MFC. При помощи него 
можно определить характеристики будущей DLL. 

AppWizard ATL COM — это средство позволяет создать 
элемент управления ActiveX или сервер автоматизации, исполь-
зуя новую библиотеку шаблонов ActiveX (ActiveX Template 
Library — ATL). Опции этого мастера дают возможность выбрать 
активный сервер (DLL) или исполняемый внешний сервер (exe-
файл). 

Custom AppWizard — при помощи этого средства можно 
создать пользовательские мастера AppWizard. Пользовательский 
мастер может базироваться на стандартных мастерах для прило-
жений MFC или DLL, а также на существующих проектах или 
содержать только определеямые разработчиком шаги. 

DevStudio Add-in Wizard — мастер дополнений позволяет 
создавать дополнения к Visual Studio. Библиотека DLL расшире-
ний может поддерживать панели инструментов и реагировать на 
события Visual Studio. 

MFC ActiveX ControlWizard — мастер элементов управле-
ния реализует процесс создания проекта, содержащего один или 
несколько элементов управления ActiveX, основанных на элемен-
тах управления MFC. 

Win32 Application — этот мастер позволяет создать проект 
обычного Window-приложения. Проект создается незаполненным, 
файлы с исходным кодом в него следует добавлять вручную. 

Win32 Console Application — мастер создания проекта кон-
сольного приложения. Консольная приложение — это программа, 
которая выполняется из командной cтроки окна DOS или 
Windows и не имеет графического интерфейса (окон). Проект 
консольного приложения создается пустым, предполагая добав-
ление файлов исходного текста в него вручную. 

Win32 Dynamic-Link Library — создание пустого проекта 
динамически подключаемой библиотеки. Установки компилятора 
и компоновщика будут настроены на создание DLL. Исходные 
файлы следует добавлять вручную. 

Win32 Static Library — это средство создает пустой проект, 
предназначенный для генерации статической (объектной) библио-
теки. Файлы с исходным кодом в него следует добавлять вручную. 
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1.7 Создание проекта VC++ 
 
Самым распространенным в мире учебным и производст-

венным пакетом программ является продукт фирмы Microsoft — 
Visual Studio 6.0, в состав которого входит среда программирова-
ния Visual С++. Несмотря на то, что в настоящее время уже су-
ществует новое поколение среды разработки Visual Studio.NET, 
VC++ версии 6.0 не потеряло своих возможностей. 

При выполнении лабораторных работ мы будем использо-
вать среду разработки Visual C++ 6.0. А так как эта среда требует 
определенных действий для создания программы, кроме написа-
ния исходного кода, то мы сейчас их и рассмотрим. 

 
1.8 Выбор типа проекта 
 
Итак, для написания программы нам необходимо создать 

проект (рабочее пространство). Для этого необходимо запустить 
Microsoft Visual C++ 6.0. После чего выполняем команду: File — 
New, или нажимаем сочетание клавиш Ctrl+N. Когда вы выпол-
ните эти действия, появится диалоговое окно, такое же, как при-
ведено на рис. 1. 

 

 
 

Рис.1 — Диалоговое окно выбора типа проекта 
 
В этом окне выбираем тип проекта Win32 Consol Applica-

tion, так как пока будем работать с консольным проектом. В поле 
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Project name вводим название нашего проекта, в нашем случае это 
MyProject. Теперь нажимаем кнопку Ok. После этого появятся еще 
два диалоговых окна. В первом ничего не меняем, а просто нажи-
маем кнопку Finish, т.е. создадим пустой проект. Пример второго, 
возникающего при выборе проекта окна расположен на рис. 2. 

 

 
 

Рис. 2 — Второе диалоговое окно выбора проекта 
 
Во втором диалоговом окне нажимаем Ok. После выполне-

ния команды Finish появляется третье окно, которое показано на 
рис. 3. 

 
 

Рис. 3 — Третье диалоговое окно выбора проекта 
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Вот и все, наш проект готов, но в нем ничего нет. Теперь 
нам необходимо добавить файлы. Пока ограничимся всего одним 
файлом. В дальнейшем, когда необходимы будут несколько фай-
лов или другие параметры проекта, мы вернемся к теме создания 
проектов и добавления файлов. А пока выполняем следующие 
действия. Выполнить команду: File — New (или нажать клавиши 
Ctrl+N). После чего появится диалоговое окно, аналогичное окну 
создания проекта. Вид этого окна приведен на рис.4. В появив-
шемся диалоговом окне приведено множество типов файлов, с 
которыми может работать VC++, однако для проектов C++ , как 
вам известно, необходимо выбрать *.cpp и *.h. 

 

 
 

Рис. 4 — Выбор типа файла для проекта  
(в нашем случае С++) 

 
Здесь выбираем тип файла C++ Source File, в поле File name 

вводим название нашего файла (в данном случае это будет main). 
Нажимаем кнопку Ok. 

Теперь у нас проект готов. Давайте напишем первую про-
грамму. 

Итак, в созданном нами файле пишем следующий код: 
 

#include <iostream.h> 
void main() 
{ 
 cout << "Hello World" << endl; 
} 
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Разбирать текст программы мы не будем, так как он прост 
(необходимо вывести на экран фразу «"Hello World"»). Мы же 
просто запустим программу. Для этих целей можно отдельно 
производить компиляцию, отдельно компоновку и после этого 
запускать программу, однако все эти действия можно выполнить 
одновременно. Для этого нажимаем клавиши Ctrl+F5 (есть и дру-
гие способы выполнения этого действия, но это самое простое, на 
мой взгляд). Появится окно сообщения, нажимаем Ok в этом ок-
не. Если программа написана без синтаксических ошибок и вы 
выполнили все действия правильно, то программа будет отком-
пилирована, скомпонована и запущена на выполнение. Вы уви-
дите результат выполнения вашей программы, аналогичный то-
му, что приведен на рис. 5. 

 

 
 

Рис. 5 — Результат выполнения первой программы 
 
Вот и все, проект готов, написана первая программа. Теперь 

можете переходить к изучению всех остальных примеров. 
 
1.9 Добавление файлов и классов в проект 
 
На данном этапе мы рассмотрим добавление файлов в про-

ект, а также добавление классов. В среде Visual C++ при добав-
лении классов при помощи встроенного «конструктора» для каж-
дого класса создается свой файл. Мы не будем отходить от этого 
и тоже пока будем создавать для каждого класса свой файл. Но 
это не стоит принимать как руководство к действию, так как в не-
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которых случаях это бесполезно или может отрицательно сказаться 
на всем проекте. Выше уже было сказано, что классы в проект 
можно добавлять посредством конструктора, который добавляет 
много разнообразной информации, которая на первых шагах может 
сильно запутать неопытного программиста. Поэтому пока мы бу-
дем добавлять классы вручную, но в последующих шагах рассмот-
рим способ добавления классов посредством конструктора. 

Создадим свой класс, описание которого поместим в файл 
MyClass.h, а его реализацию поместим в файл MyClass.cpp. 

Для выполнения этого откроем наш проект, который мы соз-
дали в шаге создания проекта. Для открытия проекта нужно вы-
полнить следующее действие: запускаем среду Visual C++, в ме-
ню выбираем "File", а здесь, в свою очередь, выбираем пункт 
"Open Workspace". Обратите внимание, что выбираем этот пункт, 
а не просто функцию "Open", так как пункт "Open" предназначен 
для открытия других фалов, а не файла проекта. После того как 
Вы выполнили вышеописанное действие, появится диалоговое 
окно открытия проекта, см. рис. 6. 

 

 
 

Рис. 6 — Диалоговое окно "Open Workspace" 
 
Здесь мы "добираемся" до нашего файла проекта. В данном 

случае — это будет файл MyProject.dsw. Выбираем его и нажима-
ем "Открыть". Стоит отметить, что файлы проектов имеют рас-
ширение dsw.  
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Рис. 7 — Результат открытия проекта 
 
После открытия проекта вы должны увидеть следующий ре-

зультат, как на рис. 7. 
Немного рассмотрим окно среды Visual C++ 6.0. Так, в ле-

вой части экрана Вы можете увидеть менеджер проекта, в кото-
ром имеется несколько закладок (в данном случае 2, но в боль-
шинстве 3). Первая закладка ClassView. На ней отображаются 
классы, их методы и поля, а также глобальные функции. Вторая 
закладка, которую мы здесь наблюдаем, — это FileView, на кото-
рой отображаются все файлы нашего проекта (см. рис. 8). 

 

 
 

Рис. 8 — Менеджер проектов  
(открыта опция "FileView") 
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Проект мы открыли, теперь перейдем к созданию класса. 
Для этого добавим еще два файла к нашему проекту (MyClass.h и 
MyClass.cpp). В этих целях выполним следующие действия. Вы-
бираем пункт "New" в меню "File" (или, что на мой взгляд, про-
ще, нажимаем сочетание клавиш Ctrl+N). После этого появится 
диалоговое окно, которое было рассмотрено в шаге создания 
проекта (там же мы добавляли файл main.cpp немного ранее). 
Здесь для добавления файла MyClass.cpp производим те же дейст-
вия, только изменяем имя файла. После того, как файл *.cpp до-
бавлен, добавим файл MyClass.h. Для этого выполняем аналогич-
ные действия с той лишь разницей, что выбираем опцию выбора 
типа файла проекта "C/C++ Header File", а не "C++ Source File". 

Теперь подключим наш файл (MyClass.h) к проекту. Для 
этого открываем файл main.cpp (не через Open, а через FileView) 
и в нем дописываем такую строку: #include "MyClass.h". Заметьте, 
что стандартные файлы мы описываем (равнозначно — вызываем) 
с помощью операторов С++ < >, а созданные пользователем — 
через " ". Теперь мы получим такой код в файле main.cpp: 

 
#include <iostream.h> 

#include "MyClass.h" 
void main() 

{ 
 cout << "Hello World" << endl; 

} 

 
Теперь немного преобразуем наш файл main.cpp и напишем 

некоторый текст в остальных файлах. Описывать действия про-
граммы не будем, так как мы здесь рассматриваем работу со сре-
дой VC++, а не объектное программирование.  

После внесения изменений имеем: 
 

//Файл main.cpp 
#include "MyClass.h" 

void main() 
{ 

 CPrint pr("Hello World"); 
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 pr.Show(); 

} 
 

//Файл MyClass.h 
class CPrint 

{ 
char m_str[100]; 

 
public: 

 CPrint(const char *pStr); 
 void Show(); 

 ~CPrint(); 
}; 

 
//Файл MyClass.cpp 

#include "MyClass.h" 
#include <string.h> 

#include <iostream.h> 
 

CPrint::CPrint(const char *pStr) 
{ 

 strcpy(m_str, pStr); 
} 

 
CPrint::~CPrint() 

{ 
cout << "Destroy object" << endl; 

} 
void CPrint::Show() 

{ 
cout << m_str << endl; 

} 
 

После написания всего исходного текста собираем про-
грамму и запускаем на выполнение (как это делается, мы уже 
рассматривали). 
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Если все было сделано правильно и вы не допустили ни од-
ной ошибки при написании исходных текстов, то получите ре-
зультат, показанный на рис. 9. 

 

 
 

Рис. 9 — Результат выполнения исправленного проекта 
 
Если же были допущены ошибки, то компилятор выдаст об 

этом сообщение. Как использовать эти сообщения для облегче-
ния поиска ошибок, мы рассмотрим в другом шаге. 

 
1.10 Создание классов посредством мастера 
 
В этой статье мы рассмотрим создание классов при помощи 

мастера. Для этого мы создадим новый пустой консольный про-
ект с именем WizardProject (как создавать проект, я надеюсь, Вы 
ужу усвоили). После создания нового проекта добавьте в него 
файл main.cpp. 

 

 
 

Рис.10 — Верхняя часть окна  
менеджера проектов. 
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На рис. 10 мы видим часть закладки, на которой отобража-
ется наш проект. Для добавления нового класса к проекту необ-
ходимо выполнить следующие действия: установить указатель 
мыши на строку, отображающую название проекта (в нашем 
примере это WizardProject classes), щелкнуть правой кнопкой 
мыши и в появившемся меню выбрать пункт <New Class:>. После 
выполнения этого действия вы увидите диалоговое окно, в кото-
ром мы указываем название нового класса. Мастер автоматиче-
ски генерирует названия h и cpp файлов, при желании мы можем 
изменить эти названия. 

На рис. 11 приведен пример диалогового окна, о котором 
говорилось выше. 

 

 
 

Рис.11 — Окно формирования данных  
о разрабатываемом классе 

 
Здесь в поле <Name> мы вводим название нашего нового 

класса. Для нашего примера создадим класс CStudent. Поля и ме-
тоды этого класса будем добавлять на другом шаге. 

Теперь рассмотрим возможность изменения имен *.h и *.cpp 
файлов. Для изменения имен этих файлов нажмем кнопку 
<Change:>. После чего появится диалоговое окно, пример которо-
го приведен на рис. 12. 
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Рис.12 — Окно изменения имен файлов проекта 
 
1.11 Добавление полей и методов мастером 
 
В этой части мы рассмотрим добавление полей данных и 

методов к нашему проекту, созданному на прошлом шаге, по-
средством мастера. Для этого откроем проект WizardProject.  

Добавим к нашему классу CStudent такие поля данных:  
 

char m_szName[100] (фамилия),  

int m_nAge (возраст),  
char m_szGroup[100] (группа, в которой обучается студент).  

 

Добавим методы:  
 

void SetName(const char *pName) (метод, посредством которого будем за-
давать фамилию студента),  
void SetAge(int nAge) (метод, посредством которого будем задавать возраст 
студента),  
void SetGroup(const char* pGroup) (метод для задания группы, в которой 

обучается студент),  
void Show() (метод, для отображения всех установленных данных). 

 

Для добавления вышеописанных полей выполняем: на 
вкладке ClassView щелкаем правой кнопкой мыши по классу 
CStudent и выбираем пункт меню <Add Member Variable:>, как 
это показано на рис. 13. После выполнения этого действия поя-
вится диалоговое окно, аналогичное приведенному на рис. 14. 
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Рис.13 — Выбор опции добавления  
полей данных 

 

 
 

Рис.14 — Окно занесения полей данных 
 
Здесь в поле <Variable Type> вводим тип поля, а в поле 

<Variable Name> указываем имя поля (но так как мы имеем дело 
с массивом/строкой, то указываем и размерность массива). В 
этом же окне указываем модификатор доступа (в данном случае 
private) и нажимаем <Ok>. Добавление остальных полей анало-
гично, за исключением поля возраста, там указывать размерность 
не нужно. 

Практически также производится добавление методов клас-
са. Немного рассмотрим этот процесс. Для добавления нового 
метода классу производим действия, аналогичные описанным 
выше, за исключением того, что в меню выбираем пункт <Add 
Member Function:>. Появится диалоговое окно, аналогичное окну 
добавления полей класса; пример окна приведен на рис. 15. 
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Рис. 15 — Окно добавления полей класса 
 

Здесь в поде <Function Type:> указываем тип функции, в по-
ле <Function Declaration:> объявляем метод, также здесь можем 
указать модификатор доступа и нажимаем Ok. Таким же образом 
добавляем остальные методы класса CStudent. 

Теперь внесем некоторые изменения. После этого файлы 
должны выглядеть следующим образом: 

 

//файл main.cpp 
#include "CStudent.h" 
void main() 
{ 
 CStudent Student; 
 Student.SetName("Ivanov"); 
 Student.SetAge(20); 
 Student.SetGroup("925-15"); 
 Student.Show(); 
} 
//файл CStudent.cpp 
// CStudent.cpp: implementation of the CStudent class. 
#include "CStudent.h" 
#include <string.h> 
#include <iostream.h> 
// Construction/Destruction 
CStudent::CStudent() : m_nAge(0) 
{ 
   memset((void*)m_szName, 32, 100); 
   memset((void*)m_szGroup, 32, 100); 
} 
CStudent::~CStudent() 
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{ 
} 
void CStudent::SetName(const char *pName) 
{ 
   strcpy(m_szName, pName); 
} 
 
void CStudent::SetAge(int nAge) 
{ 
   m_nAge = nAge; 
} 
void CStudent::SetGroup(const char *pGroup) 
{ 
   strcpy(m_szGroup, pGroup); 
} 
void CStudent::Show() 
{ 
cout << "Name:\t" << m_szName << endl 
       << "Age:\t" << m_nAge << endl 
       << "Group:\t" << m_szGroup << endl; 
} 
  

Собираем программу и запускаем на выполнение. Если все 
сделано безошибочно, то Вы увидите такой результат, который 
показан на рис. 16. 

 

 
 

Рис. 16 — Окно результата запуска программы 
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Отметим, что, несмотря на солидный возраст данного ком-
пилятора и среды разработки, он пользуется заметным успехом 
благодаря эффективности и надежности разрабатываемых в нем 
программ. Среда разработки проста и понятна начинающим про-
граммистам. 
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2 СРЕДА РАЗРАБОТКИ VISUAL C++ 2005 
 
На замену компилятора VC++ 6.0 фирма Microsoft разрабо-

тана новую линейку компиляторов, которая теперь стала нумеро-
ваться не цифрами, а годом выпуска. Начиная с компилятора 
VC++2005, структура оконного интерфейса среды разработки ма-
ло меняется и данного в пособии материала достаточно, чтобы 
понять основной принцип работы последующих компиляторов 
(VC++2008, VC++2010 и VC++2012). 

 
2.1 Пользовательский интерфейс 
 
Внешний вид пользовательского интерфейса среды про-

граммирования приведен на рис. 17. 
 

 
 

Рис.17 — Внешний вид окна рабочего пространства среды 
 
Для графического отображения объектов рабочей области 

(см. рис. 18) используется список с древовидным отображени-
ем, корневыми узлами которого являются проекты. Содержи-
мое этих проектов можно представить тремя способами, каж-
дому из которых соответствует вкладка в нижней левой части 
рабочей области: 



 31 

 
 

Рис.18 — Графическое отображение объектов на вкладке ClassView 
 
ClassView — представляет программу в объектно-ориенти-

рованном виде, отображая классы С++, их методы и члены-
данные (левая верхняя панель, см. рис. 18). Двойной щелчок та-
кого объекта вызовет переход к его объявлению или реализации. 

Project Manager — отображает ресурсы, сгруппированные 
по категориям (см. рис. 19).  

 

 
 

Рис. 19 — Графическое отображение объектов на вкладке Project Manager 
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Show All Files — показывает все файлы проекта, которые 

можно редактировать (см. рис. 20). 
 

 
 

Рис. 20 — Графическое отображение объектов  
на вкладке Show All Files 

 
При щелчке правой кнопкой мыши на объекте появится 

контекстное меню, пункты которого связаны с этим объектом. 
 

2.2 Меню и панели инструментов 
 
Среда разработки Visual C++ Express Editor обладает набо-

ром меню, позволяющим управлять файлами и рабочими облас-
тями проектов, настраивать саму среду, а также обращаться к 
справочной системе, программе управления исходным кодом и 
внешним инструментальным средствам. Почти каждому меню 
соответствует панель инструментов, в которой команду можно 
выбрать одним щелчком кнопки мыши. Панели инструментов 
допустимо настраивать — добавлять и удалять кнопки, скрывать 
и отображать сами панели инструментов. Поэтому Вы можете 
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сконфигурировать среду по своему вкусу, упростив доступ к час-
то используемым вами пунктам меню. 

По умолчанию в окне среды Visual C++ отображены две па-
нели инструментов. Панель Standart (содержит команды, часто 
используемые при работе с файлами), Layout (представляет ин-
струмент для работы с объектами на форме). 

При щелчке правой кнопки мыши на поле расположения 
панелей (например, в пустой правой верхней части панели инст-
рументов) появится полный список возможных панелей, позво-
ляющий скрывать и отображать панели (см. рис. 21). 

 

 
 

Рис. 21 — Выбор содержания панелей среды разработки 
 
Для настройки пользовательского интерфейса необходимо 

проделать следующие действия: 
1. В меню Tools выберите пункт Customize. Появится диа-

логовое окно Customize (см. рис. 22). 
2. Перейдите на вкладку Commands. 
3. В списке Category выберите пункт View. 
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4. Щелкните значок Full Screen (третий слева в первом ря-
ду). Обратите внимание на описание команды, которое появляет-
ся под раскрывшимся списком Category. 

5. Перетащите значок Full Screen на панель инструментов 
Standart. 

6. Закройте окно Customize. 
7. Откройте файл с исходным кодом программы, дважды 

щелкнув его в окне FullView. 
8. Испытайте новую кнопку — щелкните ее, чтобы перейти 

в полноэкранный режим. Чтобы вернуться к традиционному ви-
ду, необходимо снова щелкнуть эту кнопку. 

Чтобы удалить кнопку с панели инструментов, достаточно 
щелкнуть ее правой кнопкой мыши и выбрать из контекстного 
меню пункт Delete. 

 

 
 

Рис. 22 — Выбор опции Customize и команд входящих в ее состав 
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2.3 Настройка параметров среды 
 
Выбрав в меню Tools пункт Options, можно вызвать диало-

говое окно Options (см. рис. 23). В этом окне настраиваются па-
раметры вашей рабочей среды, от которых зависят вид и возмож-
ности встроенных в нее инструментальных средств. Данные па-
раметры применяются ко всем проектам и их конфигурациям. 

В диалоговом окне можно настроить: 
1) редактор кода — начиная с параметров окна и сохранения 

и заканчивая параметрами таких функций, как автозаполнение 
кода и цветовое выделение синтаксических элементов. Можно 
эмулировать некоторые версии редакторов; 

2) отображение информации отладчиком; 
3) параметры встроенной программы управления исходным 

кодом; 
4) пути к исполняемым файлам, файлам с исходным кодом, 

включаемым файлам и библиотекам. 
 

 
 

Рис. 23 — Работа с окном параметров Options 
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2.4 Параметры конфигурации проекта 
 
При работе над проектом в некоторых случаях возникает 

необходимость изменения параметров конфигурации проекта. Для 
этого вызовите окно Property, выбрав в меню Project пункт Prop-
erties. В этом окне можно настроить параметры проекта, в том 
числе и параметры компиляторов и компоновщика Visual C++. 

Важно отметить, что изменения параметров на любой 
вкладке влияют только на текущий проект и версию сборки, ука-
занные в раскрывающемся списке Configuration. Для каждого 
типа сборки можно задать свой набор параметров. Если требуется 
установить одинаковые параметры для всех версий сборки, в 
списке Configuration выберите All Configurations. 

Не менее важно при настройке проекта проверить, какую 
его конфигурацию вы изменяете.  

Приведем описание содержания некоторых вкладок диало-
гового окна Project Settings (см. рис. 24). 

• General — здесь можно указать, компоновать ли про-
грамму с использованием статических библиотек MFC (если Вы 
решили изменить способ компоновки, выбранной Вами в окне 
мастера Wizard). Также можно задать каталоги, в которые будут 
помещаться конечные файлы. 

• Debugging — Здесь находятся параметры, передаваемые 
программе при ее запуске в отладчике. Кроме того, можно ис-
пользовать переадресацию ввода/вывода, аналогичную приме-
няемой в командной строке. 

• C/C++ — здесь вы определяете параметры компилятора, 
функциональные возможности языка, соглашения о вызове, па-
раметры, связанные с типом процессора, оптимизации кода, кон-
стантами препроцессора и т. п. 

• Linker — на этой вкладке выбирают дополнительные 
библиотеки, которые следует скомпилировать вместе с Вашей 
программой. 
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Рис. 24 — Параметры конфигурации проекта 
 

2.5 Типы мастеров проекта 
 

В среде Visual C++ можно строить различные типы проек-
тов. Такие проекты после их создания можно компилировать и 
запускать на исполнение. Фирма Microsoft разработала специаль-
ный инструментарий, облегчающий и ускоряющий создание про-
ектов в среде Visual C++. 

Рассмотрим некоторые типы проектов, которые можно соз-
давать при помощи различных средств (мастеров проектов) 
Microsoft Visual C++: 

MFC AppWizard (exe) — при помощи этого мастера прило-
жений можно разработать проект Windows-приложения, имею-
щего однодокументный, многодокументный или диалоговый ин-
терфейс. Однодокументное приложение может предоставлять 
возможность пользователю в любой момент времени работать 
только с одним документом в окне. Многодокументное приложе-
ние, напротив, может одновременно представлять несколько до-
кументов, каждый в собственном окне. Пользовательский интер-
фейс диалогового приложения представляет собой единственное 
диалоговое окно. 
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MFC AppWizard (dll) — этот мастер приложений позволяет 
создать структуру DLL, основанную на MFC. При помощи него 
можно определить характеристики будущей DLL. 

AppWizard ATL COM — это средство позволяет создать эле-
мент управления ActiveX или сервер автоматизации, используя но-
вую библиотеку шаблонов ActiveX (ActiveX Template Library — 
ATL). Опции этого мастера дают возможность выбрать активный 
сервер (DLL) или исполняемый внешний сервер (exe-файл). 

Custom AppWizard — при помощи этого средства можно 
создать пользовательские мастера AppWizard. Пользовательский 
мастер может базироваться на стандартных мастерах для прило-
жений MFC или DLL, а также на существующих проектах или 
содержать только определеямые разработчиком шаги. 

DevStudio Add-in Wizard — мастер дополнений позволяет 
создавать дополнения к Visual Studio. Библиотека DLL расшире-
ний может поддерживать панели инструментов и реагировать на 
события Visual Studio. 

MFC ActiveX ControlWizard — мастер элементов управле-
ния реализует процесс создания проекта, содержащего один или 
несколько элементов управления ActiveX, основанных на элемен-
тах управления MFC. 

Win32 Application — этот мастер позволяет создать проект 
обычного Window-приложения. Проект создается незаполненным, 
файлы с исходным кодом в него следует добавлять вручную. 

Win32 Console Application — мастер создания проекта кон-
сольного приложения. Консольное приложение — это программа, 
которая выполняется из командной cтроки окна DOS или 
Windows и не имеет графического интерфейса (окон). Проект 
консольного приложения создается пустым, предполагая добав-
ление файлов исходного текста в него вручную. 

Win32 Dynamic-Link Library — создание пустого проекта 
динамически подключаемой библиотеки. Установки компилятора 
и компоновщика будут настроены на создание DLL. Исходные 
файлы следует добавлять вручную. 

Win32 Static Library — это средство создает пустой проект, 
предназначенный для генерации статической (объектной) биб-
лиотеки. Файлы с исходным кодом в него следует добавлять 
вручную. 
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2.6 Выбор типа проекта 
 
Для создания нового проекта выберите в меню File 

=>New=>Project, на экране появится форма мастера проекта; в 
зависимости от решаемой вами задачи выберите тип проекта, 
дайте название вашему проекту, далее нажмите кнопку Ok. Мас-
тер подготовит необходимые формы и сгенерирует код — так на-
зываемую оболочку для дальнейшей разработки вашего проекта. 

Создание проекта. В этом окне выбираем тип проекта 
Win32 Consol Application (см. рис. 25), так как пока будем рабо-
тать с консольным проектом. В поле name вводим название на-
шего проекта, в нашем случае это MyProject. Теперь нажимаем 
кнопку Ok. После этого появятся еще два диалоговых окна. В 
первом ничего не меняем, а просто нажимаем кнопку Finish, т.е. 
создадим пустой проект. 

 

 
 

Рис. 25 — Окно выбора типа проекта 
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2.7 Добавление файлов в проект 
 
Создадим свой класс, описание которого поместим в файл 

MyClass.h, а его реализацию поместим в файл MyClass.cpp. 
Для выполнения этого откроем наш проект, который мы 

создали в шаге создания проекта (см. рис. 26). Для открытия про-
екта нужно выполнить следующее действие: запускаем среду 
Visual C++, в меню выбираем "File", а здесь, в свою очередь, вы-
бираем пункт "Open=>Progect". Обратите внимание, что выбира-
ем этот пункт, а не просто функцию "Open". Так как пункт 
"Open" предназначен для открытия других фалов, а не файла про-
екта программы.  

 

 
 

Рис. 26 — Элементы первой программы в среде  
программирования Visual C++ 

 
Теперь подключим наш файл (MyClass.h) к проекту. Для 

этого открываем файл main.cpp (не через Open, а через FileView) 
и в нем дописываем такую строку: #include "MyClass.h" (см. 
рис. 27).  
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Рис. 27 — Добавление подключаемых файлов в проект 
 
2.8 Создание классов по средством мастера 
 
Рассмотрим некоторые действия для создание классов при 

помощи мастера. Для этого мы создадим новый пустой консоль-
ный проект с именем WizardProject (см. рис. 28). После создания 
нового проекта добавьте в него файл main.cpp. 

Для добавления нового класса к проекту необходимо вы-
полнить следующие действия: установить указатель мыши на 
строку, отображающую название проекта (в нашем примере это 
WizardProject classes (см. рис. 29)), щелкнуть правой кнопкой 
мыши и в появившемся меню выбрать пункт Add =>Class. После 
выполнения этого действия Вы увидите диалоговое окно, в кото-
ром мы указываем название нового класса. Мастер автоматиче-
ски генерирует названия h и cpp файлов, при желании мы можем 
изменить эти названия. 
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Рис. 28 — Окно интерфейса создания нового консольного проекта  
с именем WizardPro 

 

 
 

Рис. 29 — Окно формирования данных о разрабатываемом классе 
 
Здесь в поле <Class Name> мы вводим название нашего но-

вого класса. Для нашего примера создадим класс CStudent (см. 
рис. 30). Далее нажимаем кнопку Finish Поля и методы этого 
класса будем добавлять на другом шаге (см. рис. 31). 
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Рис. 30 — Заполнение элементов окна создания файлов проекта 

 

 
 

Рис. 31 — Окно созданного нашего класса и добавленного в проект 
 
На рис. 31 показано заполнение поля программы Student.h 

элементами программы. 
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2.9 Пример программы вывода текста на экран 
 

#include <iostream>  
void main() 

{ 
 /*Эта программа выводит вопрос 
 как вас зовут ?*/ 
 char name[20]; 

 std::cout<<"What is your name:\n"; 
 std::cin >>name; 

 std::cout<<"Hello:"<<name; 
} 

Результата работы программы: 
 

 
 

Рис. 32 — Результат работы программы 
 
На рис. 32 показан результат запуска программы, который 

определяется выводом вопроса об имени пользователя, чтении 
имени пользователя и последующего отображения этого имени. 
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3 ЛАБОРАТОРНЫЕ РАБОТЫ ПО ОБЪЕКТНО-
ОРИЕНТИРОВАННОМУ ПРОГРАММИРОВАНИЮ 

 

Выбор варианта лабораторных работ осуществляется по 
общим правилам с использованием следующей формулы:  

V = (N*K) div 100, 
где  V — искомый номер варианта, 

N — общее количество вариантов, 
div — целочисленное деление, 
при V= 0 выбирается максимальный вариант, 
K — значение 2-х последних цифр пароля. 
Варианты заданий представлены в табл. 3.1, в которой дан 

минимальный набор параметров, необходимый для выполнения 
лабораторных работ. В представленных ниже двух лабораторных 
работах дан пример создания объекта с определенным набором 
данных. Студент вправе увеличивать число параметров объекта и 
определять им необходимый для этого тип, но не уменьшать их 
относительно табл. 3.1. 

 

Таблица 3.1 — Варианты заданий описания членов — данных 
пользовательских классов 
   
1. СТУДЕНТ 
имя — char* 
курс — int 
пол — int(bool) 
 

2. ИЗДЕЛИЕ 
имя — char* 
шифр — char* 
количество — int 
 

3. АДРЕС 
имя — char* 
улица — char* 
номер дома — int 
 

4. ЦЕХ 
имя — char* 
начальник — char* 
количество 
работающих — int 
 

5. СТРАНА 
имя — char* 
форма 
правления — char* 
площадь — float 
 

6. СЛУЖАЩИЙ 
имя — char* 
возраст — int 
рабочий стаж — int 
 

7. БИБЛИОТЕКА 
имя — char* 
автор — char* 
стоимость — float 
 

8. ТОВАР 
имя — char* 
количество — int 
стоимость — float 
 

9. ПЕРСОНА 
имя — char* 
возраст — int 
пол — int(bool) 
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10. ЖИВОТНОЕ 
имя — char* 
класс — char* 
средний вес — int 
 

11. КАДРЫ 
имя — char* 
номер цеха — int 
разряд — int 
 

12. ЭКЗАМЕН 
имя студента — char* 
дата — int 
оценка — int 
 

13. КВИТАНЦИЯ 
номер — int 
дата — int 
сумма — float 
 

14. АВТОМОБИЛЬ 
марка — char* 
мощность — int 
стоимось — float 
 

15. КОРАБЛЬ 
имя — char* 
водоизмещение — int 
тип — char* 
 

16. КНИГА 
номер по списку — int 
автор — char 
сумма — float 
 

17. СОТОВЫЙ 
марка — char 
номер — int 
сумма — float 
 

18. САМОЛЕТ 
рейс — int 
дата — int 
сумма — float 
 

19. ПРИНТЕР 
марка — char 
номер — int 
сумма — float 
 

20. ЛИНЕЙКА 
длина — int 
ширина — int 
сумма — float 
 

21. ДОГОВОР 
номер — int 
руководитель — char 
сумма — float 
 

22. КНОПКА 
диаметр — int 
тип — char 
длина жала — float 
 

23. МЫШЬ 
марка — char 
число кнопок — int 
сумма — float 
 

24. ЦВЕТОК 
тип — char 
дата — int 
сумма — float 
 

25. СТУЛ 
число ножек — int 
число спинок — int 
сумма — float 
 

26. КАРТА 
тип — char 
масштаб — int 
полушарие — char 
 

27. СТЕКЛО 
толщина — int 
цвет — int 
марка — char 
 

 
 
 
 
 
 

Окончание табл. 3.1 
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3.1 Работа № 1 
 
Тема: Классы. Открытые и закрытые уровни доступа. 

Конструкторы. Инициализация данных объекта. Определение 
методов. Создание объекта в памяти. Стандартные потоки 
ввода-вывода. 

 
1. В среде программирования на С++ создайте консольный 

проект с именем LAB1 в каталоге LAB1. 
2. В проекте создайте файлы main.h (заголовочный файл) и 

main.cpp (файл исходного кода). 
3. В файле main.h определите с помощью ключевого слова 

class объект Person. 
Данные объекта:  
Номер человека (целый тип). 
ФИО (символьный массив). 
Пол (логический тип: 0 — муж., 1 — жен.). 
Возраст (вещественный тип). 
 
Пусть данные имеют закрытый уровень доступа (private).  
4. Опишите конструктор объекта, аргументы которого будут 

инициализировать все данные объекта.  
5. Опишите конструктор объекта по умолчанию (без аргу-

ментов), проинициализировав все данные. 
6. Опишите в объекте функцию void Print() с открытым уров-

нем доступа (public), которая будет выводить данные на экран.  
7. Откройте файл main.cpp. С помощью директивы #include 

включите в файл main.cpp заголовочные файлы <stdlib.h>, 
<string.h>, <iostream.h>, а также ваш заголовочный файл 
"Main.h". 

8. Ниже определите конструктор объекта, инициализирую-
щий все данные объекта значениями аргументов. В теле конст-
руктора используйте функцию strcpy(стр1, стр2) для копирования 
строки имени человека (ФИО). 

9. Затем определите функцию void Person::Print(). В теле 
функции для вывода данных используйте стандартный поток вы-
вода cout << значение1 << значение2 << … << endl;. 
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10. Ниже напишите главную функцию программы int 
main(). Внутри ее создайте объект Person, указав все значения 
данных объекта. Выведите данные объекта на экран, вызвав 
функцию Print.  

11. Затем создайте динамический объект Person с помощью 
обычного конструктора и оператора new. Выведите данные объ-
екта на экран. Удалите динамический объект из памяти с помо-
щью оператора delete.  

12. Напишите функцию ввода данных в объект с клавиатуры 
void Person::Input(). В теле функции для ввода данных используйте 
стандартный поток ввода cin >> значение1 >> значение2 >> …; 

13. Затем в теле функции main создайте объект Person с по-
мощью конструктора по умолчанию и введите данные в объект с 
клавиатуры, вызвав функцию Input. Выведите данные объекта на 
экран.  

 
3.2 Работа № 2 
 
Тема: Создание динамического массива объектов. Дест-

руктор объекта. Два типа полиморфизма: принудительное при-
ведение типа, перегрузка функций и перегрузка операторов 
(унарных и бинарных). 

 
1. В среде программирования на С++ создайте консольный 

проект с именем LAB2 в каталоге LAB2. 
2. Переименуйте файл main.h из предыдущей лабораторной 

в person.h. Создайте файл person.cpp и включите в проект эти два 
файла. Переместите конструктор и функции объекта Person из 
main.cpp в файл person.cpp. Таким образом, файл person.h содер-
жит описание объекта Person, а файл person.cpp — реализацию 
объекта Person.  

3. Включите в проект файл main.cpp и очистите тело функ-
ции main(). 

4. Определим объект Group, который будет содержать ди-
намический массив объектов Person. Создайте два файла group.h 
и group.cpp и включите их в проект. 

5. В файле group.h определите с помощью ключевого слова 
class объект Group. 
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Данные объекта:  
 
размер массива (целый тип) 
указатель на массив (тип Person*). 
 
Пусть данные имеют закрытый уровень доступа (private). 
6. Опишите конструктор объекта с одним аргументом — 

размер массива (целый тип) и деструктор объекта. 
7. Откройте файл group.cpp. С помощью директивы #include 

включите необходимые заголовочные файлы. 
8. Определите конструктор объекта Group. В теле конструк-

тора проинициализируйте данные объекта, т.е. проинициализи-
руйте размер массива значением аргумента конструктора и выде-
лите динамическую память под массив с помощью строки кода:  

 
указатель на массив = new Person[размер массива]. 
 
9. В деструкторе объекта освободите память, занимаемую 

массивом, с помощью строки кода  
 
delete [] указатель на массив.  
 
Таким образом, мы создали объект Group, который содер-

жит массив объектов Person.  
10. Определим открытые (public) методы для объекта 

Group. Напишите функцию void Group::Print(), которая выводит 
в цикле for все записи массива на экран. В теле цикла примените 
ранее написанную функцию Print() для объекта Person. 

11. Напишите функцию int Group::Size(), которая возвраща-
ет размер массива. 

12. Напишите функции void PutPerson(int i, Person& man); и 
Person& GetPerson(int i);, первая функция заносит объект man 
типа Person в i-й элемент массива, вторая функция возвращает 
объект типа Person из i-го элемента массива.  

13. Заполните массив данными и затем выведите их на эк-
ран. Для этого в теле функции int main() сначала определите мас-
сив имен, которые будут заносится в поле ФИО объекта Person, 
например,  
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char names[5][25] = {"A", "B", "C", "D", "E"};.  
 
Затем создайте объект с именем group типа Group размером 

пять записей, т.е. Group group(5);. 
14. Ниже с помощью цикла for заполните массив данными. 

Для этого в теле цикла создайте объект Person, проинициализи-
ровав все его данные, и с помощью функции PutPerson занесите 
объект в массив. 

15. Выведите массив на экран с помощью строки кода: 
group.Print();. Получилось? Если да, то вы научились создавать 
динамический массив объектов, определять функции работы с 
таким массивом и выводить его на экран. 

16. В этой части лабораторной работы изучим первые два 
типа полиморфизма — это а) принудительное приведение типа; 
б) перегрузка функций и операторов.  

17. Напишите функцию приведения типа. Для этого с по-
мощью ключевого слова operator напишите функцию объекта 
Person, которая преобразует тип Person в double. Пусть функция 
возвращает возраст человека, например,  

 
Person::operator double() { return this->Age; }.  
 
Что означает ключевое слово this? 
18. Проверьте функцию преобразования типа. В функции 

int main() далее определите переменную double и присвойте ей 
объект Person, например: 
 

double age = group.GetPerson(2);.  
 
То есть совершается неявное преобразование из типа Person 

в тип double при обращении к объекту. Выведите значение пере-
менной на экран. 

19. Перегруженные функции имеют одинаковое название, 
но разный возвращаемый тип или/и разный список аргументов. 
Определим в объекте Group две функции с одинаковым именем, 
например double Age(); и double Age(int limit);. Первая функция 
пусть возвращает средний возраст группы людей, а вторая функ-
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ция пусть возвращает средний возраст людей в группе, возраст 
которых не больше некоторого граничного значения limit. Функ-
ции отличаются списком аргументов. 

20. Проверьте работу перегруженных функций, отобразив 
на экране подсчитанные два значения среднего возраста. 

21. Перегрузите оператор индексирования. Если раньше, 
чтобы обратиться к элементу массива, нам необходимо было вы-
зывать функцию GetPerson, то, определив оператор индексирова-
ния, мы будем использовать только квадратные скобки. Сравните 
две строки кода: 

 
Person man = group.GetPerson(2); 
Person man = group[2]; 
 
В объекте Group с помощью ключевого слова operator опре-

делите оператор индексирования, например:  
 
Person& Group::operator[](int i).  
 
В теле оператора напишите код, возвращающий i-ый эле-

мент массива, т.е. объект Person. 
22. Выведите на экран с помощью оператора индексирова-

ния любой один элемент массива group, например третий.  
23. Перегрузим бинарный оператор, например оператор 

сложения (+), для объекта Person. Пусть оператор сложения бу-
дет возвращать суммарный возраст двух человек. Опишем в объ-
екте Person данный оператор как дружественную функцию с по-
мощью ключевого слова friend, например: 

   
 friend double operator+(Person& p1, Person& p2); 
 
Эта строка кода означает, что оператор сложения не при-

надлежит объекту, но ему доступны все закрытые данные и мето-
ды объекта. 

В файле person.cpp определите оператор сложения, например: 
 
double operator + (Person& p1, Person& p2) 
                               { return (p1.Age + p2.Age); } 
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Здесь мы напрямую обращаемся к закрытому полю Age объ-
екта Person. 

24. Проверим работу оператора с помощью следующих 
строк кода: 
 

double sum = group[1] + group[3];   
cout << sum << endl; 
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4 ПРАВИЛА ОФОРМЛЕНИЯ ЛАБОРАТОРНЫХ РАБОТ 
 
а) Лабораторная работа состоит в выполнении задания, опи-

сания материала в формате MS WORD и подготовке файлов про-
екта (файлы *.ехе, *.cpp, *.h). Выполнение задания может быть 
выполнено в любой среде программирования С++, но с обяза-
тельным ее указанием в файле отчета (дело в том, что существу-
ют некоторые отличия программирования в средах, например 
Visual Studio и Borland). 

 
б) Лабораторная работа обязательно должна содержать: 
– краткое изложение теоретического материала по каждому 

из рассматриваемых разделов в лабораторной (например, указа-
тель, наследование, др.); 

– комментарии по тексту программы, описывающие основ-
ные особенности объектно-ориентированного программирования 
на С++; 

– дополнения (создания нового класса, применение насле-
дования, полиморфных и дружественных функций и др.) и изме-
нения, приводящие к усложнению варианта лабораторных работ. 

 
в) Окончательно сформированное задание содержит файл 

описания *.word и файлы проекта *.ехе, *.cpp, *.h. 
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